Author Topic: RFduino Board compile error  (Read 205 times)

Deaniesaur

  • RFduino Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
RFduino Board compile error
« on: August 31, 2017, 01:21:27 AM »
Just yesterday, compiling and uploading codes from my PC to the RFduino module is flawless. But this day Aug 31, 2017. I can't seem to compile any code to RFduino module. I even tried the most basic examples for RFduino. Here is the Error Log:

Arduino: 1.8.4 (Windows 10), Board: "RFduino"

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\arduino-builder -dump-prefs -logger=machine -hardware C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\hardware -hardware C:\Users\dean_\AppData\Local\Arduino15\packages -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\tools-builder -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\hardware\tools\avr -tools C:\Users\dean_\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\libraries -libraries C:\Users\dean_\OneDrive\Mga Dokumento\Arduino\libraries -fqbn=RFduino:RFduino:RFduino -ide-version=10804 -build-path C:\Users\dean_\AppData\Local\Temp\arduino_build_165037 -warnings=none -build-cache C:\Users\dean_\AppData\Local\Temp\arduino_cache_758650 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=C:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -verbose G:\THESIS\Arduino\RFduino_Test\RFduino_Proto3\RFduino_Proto3.ino
C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\arduino-builder -compile -logger=machine -hardware C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\hardware -hardware C:\Users\dean_\AppData\Local\Arduino15\packages -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\tools-builder -tools C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\hardware\tools\avr -tools C:\Users\dean_\AppData\Local\Arduino15\packages -built-in-libraries C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86__mdqgnx93n4wtt\libraries -libraries C:\Users\dean_\OneDrive\Mga Dokumento\Arduino\libraries -fqbn=RFduino:RFduino:RFduino -ide-version=10804 -build-path C:\Users\dean_\AppData\Local\Temp\arduino_build_165037 -warnings=none -build-cache C:\Users\dean_\AppData\Local\Temp\arduino_cache_758650 -prefs=build.warn_data_percentage=75 -prefs=runtime.tools.arm-none-eabi-gcc.path=C:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\tools\arm-none-eabi-gcc\4.8.3-2014q1 -verbose G:\THESIS\Arduino\RFduino_Test\RFduino_Proto3\RFduino_Proto3.ino
Using board 'RFduino' from platform in folder: C:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\hardware\RFduino\2.3.3
Using core 'arduino' from platform in folder: C:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\hardware\RFduino\2.3.3
Detecting libraries used...
"C:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -fno-rtti -fno-exceptions -fno-builtin -w -x c++ -E -CC -mcpu=cortex-m0 -DF_CPU=16000000 -DARDUINO=10804 -mthumb -D__RFduino__ "-IC:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\hardware\RFduino\2.3.3\cores\arduino" "-IC:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\hardware\RFduino\2.3.3\variants\RFduino" "-IC:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\hardware\RFduino\2.3.3\system/RFduino" "-IC:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\hardware\RFduino\2.3.3\system/RFduino/include" "-IC:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\hardware\RFduino\2.3.3\system/CMSIS/CMSIS/Include" "C:\Users\dean_\AppData\Local\Temp\arduino_build_165037\sketch\RFduino_Proto3.ino.cpp" -o "nul"
Generating function prototypes...
"C:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\tools\arm-none-eabi-gcc\4.8.3-2014q1/bin/arm-none-eabi-g++" -c -g -Os -w -std=gnu++11 -ffunction-sections -fdata-sections -fno-rtti -fno-exceptions -fno-builtin -w -x c++ -E -CC -mcpu=cortex-m0 -DF_CPU=16000000 -DARDUINO=10804 -mthumb -D__RFduino__ "-IC:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\hardware\RFduino\2.3.3\cores\arduino" "-IC:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\hardware\RFduino\2.3.3\variants\RFduino" "-IC:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\hardware\RFduino\2.3.3\system/RFduino" "-IC:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\hardware\RFduino\2.3.3\system/RFduino/include" "-IC:\Users\dean_\AppData\Local\Arduino15\packages\RFduino\hardware\RFduino\2.3.3\system/CMSIS/CMSIS/Include" "C:\Users\dean_\AppData\Local\Temp\arduino_build_165037\sketch\RFduino_Proto3.ino.cpp" -o "C:\Users\dean_\AppData\Local\Temp\arduino_build_165037\preproc\ctags_target_for_gcc_minus_e.cpp"
arm-none-eabi-g++: error: CreateProcess: No such file or directory

exit status 1
Error compiling for board RFduino.

tolson

  • Global Moderator
  • *****
  • Posts: 866
  • Karma: +20/-0
    • View Profile
    • Thomas Olson Consulting
Re: RFduino Board compile error
« Reply #1 on: August 31, 2017, 09:26:15 AM »
Just yesterday, compiling and uploading codes from my PC to the RFduino module is flawless. But this day Aug 31, 2017. I can't seem to compile any code to RFduino module. I even tried the most basic examples for RFduino. Here is the Error Log:

Arduino: 1.8.4 (Windows 10), Board: "RFduino"

C:\Program Files\WindowsApps\ArduinoLLC.ArduinoIDE_1.8.7.0_x86

HINT: Maybe? What is ArduinoIDE_1.8.7.0_x86. Surely not Arduino 1.8.4.


 

anything