Author Topic: Compatibility with latest Arduino BETA 1.5.7  (Read 2776 times)


  • RFduino Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Compatibility with latest Arduino BETA 1.5.7
« on: July 13, 2014, 08:04:15 AM »
In the last release of the Arduino IDE, they've changed the paths in the application archive (at least on a Mac) to the ARM compilers.
That way the IDE complained about not finding the compiler, when I tried to compile for the RFduino.
I had a look into the "platform.txt" of the RFduino component for the IDE and found the value for compiler.path, which was wrong.
So for anyone, who's problems compiling change:

Code: [Select]

Code: [Select]
As there seems to be a version number included in the directory name, this could be different in your download. Maybe there is a better way to fix this, but this worked for me. I can now use this version of the IDE to compile my stuff for RFduino!


  • RFduino Team
  • *****
  • Posts: 405
  • Karma: +15/-0
    • View Profile
Re: Compatibility with latest Arduino BETA 1.5.7
« Reply #1 on: July 15, 2014, 05:46:14 PM »
Hi David, just a heads up... RFduino v2.1 supports v1.5.7