Author Topic: Using the onboard J-link on nrf51-DK  (Read 2053 times)

nrfdevel

  • RFduino Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Using the onboard J-link on nrf51-DK
« on: March 29, 2015, 09:19:51 PM »
Hi rfduino experts,

I need to access the low level BLE APIs on the rfduino which I'm trying to do through the onboard j-link provided on  Nordic's nrf51-DK. I'm connecting the debug port to the pins on rfduino through this cable following the pinouts given in the forum. However, I can not detect the device in nRFgo studio. When I connect the nordic beacon kit through the same cable, I can detect the device.
Has anyone tried connecting through the onboard jlink on nrf51-dk? Any suggestions/hints on what I should look for ?


Many thanks

chrismiles

  • RFduino Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
    • View Profile
Re: Using the onboard J-link on nrf51-DK
« Reply #1 on: March 30, 2015, 10:41:35 PM »
Yes, I've done exactly that to reprogram a RFD22301.

I hooked up four connections between NRF51-DK P19 and the RFD22301:

 EXT_VTG <--> VCC
 EXT_GND_DETECT <--> GND
 EXT_SWDIO <--> /RESET
 EXT_SWDCLK <--> FACTORY

Cheers,
Chris

nrfdevel

  • RFduino Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
    • View Profile
Re: Using the onboard J-link on nrf51-DK
« Reply #2 on: April 02, 2015, 05:11:07 AM »
Hi Chris,

Glad to know it works :) Am I missing something on the pin definitions?
I checked the connections right from nrf51-DK to the pins on RFDuino, they seem to be all fine. rfduino does provide 3.3v at the vcc but the nrfgo studio says no device detect. The fact that it says this and doesn't show the DK memory layout seems to point that it detected some voltage on the EXT_VCC pin, but I don't seem to get past this :(

Much appreciate any help!
« Last Edit: April 02, 2015, 06:45:05 AM by nrfdevel »